Connection and starting the application

Connection method

Single connection

Connect the camera directly using an Ethernet cable. Disconnect the network beforehand if the PC is connected to other networks, including Wi-Fi. It takes about 30 seconds until the camera is recognized.


Connect the camera via a router using an Ethernet cable.


Multiple connection

Although up to 20 cameras can be connected according to the specifications, we recommend connecting up to 6 cameras when you use them simultaneously.

Connect multiple cameras via a router or a hub using an Ethernet cable.

Connecting the camera

  • Camera settings

    When using the ILCE-1

    • Select MENU → (Network) → [Transfer/Remote] → [PC Remote Function] → [PC Remote] → [On]
    • Select MENU → (Network) → [Transfer/Remote] → [PC Remote Function] → [PC Remote Cnct Method] → [Wired LAN]
    Tip:
    When you connect multiple cameras, use [Edit Device Name] to change the names of the cameras before performing the camera settings, so that you can identify each camera easily.
    Select MENU → (Network) → [Network Option] → [Edit Device Name]

    When using the ILCE-9M2

    • Select MENU → (Network) → [PC Remote Function] → [PC Remote] → [On]
    • Select MENU → (Network) → [PC Remote Function] → [PC Remote Cnct Method] → [Wired LAN]
    Tip:
    When you connect multiple cameras, use [Edit Device Name] to change the names of the cameras before performing the camera settings, so that you can identify each camera easily.
    Select MENU → (Network) → [Edit Device Name]

    When using the ILCE-9

    • Select MENU → (Network) → [PC Remote(Wired LAN)] → [On]
    Tip:
    When you connect multiple cameras, use [Edit Device Name] to change the names of the cameras before performing the camera settings, so that you can identify each camera easily.
    Select MENU → (Network) → [Edit Device Name]
  • Camera connections

    Connect the camera(s) to Remote Camera Tool using any one of the above three methods in accordance with the environment for using this application.

Starting the application

Device Selection Window

  • Double click on the Remote Camera Tool icon. The "Device selection window" will appear.

  • Click the [Refresh] button. A list of the camera(s) connected to the PC will appear.

    • 1 IP address dialog box

    • 2 [Connect] button

      If no cameras appear, enter the IP address of a camera in the IP address dialog box (shown by 1), and then click the [Connect] button (shown by 2).

    • 3 [Refresh] button

    • 4 Shortcuts

      You can assign shortcuts to the cameras you wish to connect to.

    • 5 You can change the device names under the [Camera Name] column on this window.

      Note, however, that the name you changed on this window is effective only for Remote Camera Tool. The name of the camera displayed on the [Edit Device Name] menu will not change.

    • 6 Indicates camera status

      connected: The camera is connected.
      disconnected: The camera is disconnected.

    • 7 Pairing

      Done: Pairing is complete. Double-click to connect.
      Not yet: Pairing is incomplete. Double-click to open the pairing screen (refer to “How to pair” below for further instructions).
      - (dash): Displayed when you use a camera with the [Connect without Pairing] setting and set it to [Enable]. Double-click to connect.

    • 8 [Disconneted] button, [Remove] button

      Select a camera with the Status “Connected” and click the [Disconnected] button to disconnect the selected camera.
      Select a camera with the Status “Unidentified” and click the [Remove] button to remove the selected camera from the list.

      • To remove all the cameras with the Status “Unidentified” from the list, select [Tools] → [Remove Unidentified Camera].
    • 9 A list of connected camera(s) will appear.

      The cameras appear in Multi Live View in the order displayed.

    • 10 Multi Live View start button

      Select the group(s) to display in Multi Live View and click the [Multi Live View] button.
      Clicking the [Multi Live View] button starts Multi Live View.
      Multi Live View lets you display up to 20 cameras. Multi Live View does not start if the number of cameras in the selected group(s) is 0 or 21 or more.

    • 11 [File Import] button (ILCE-1 Ver. 1.3 or later only)

      Transfers images from a camera to the computer.
      After selecting a camera with the Status “Disconnected,” click the [File Import] button to connect to the camera and display the number of files to be transferred.
      Select the folder in which to store the transferred files and click [OK] to start transferring the images.

      • To import images from a camera, the camera must be disconnected from the computer.
      • The files that are transferred are the images stored on the media card in the slot specified by [Select Playback Media] on the camera.

Using the Network Configuration File

You can display in a device selection window only cameras with the IP addresses given in advance in a file by using Network Configuration File. This means you can eliminate the trouble of manually inputting IP addresses.

From the menu bar, select [File] → [Network Configuration File Setting].
Follow the instructions on the screen to specify the file containing items such as IP addresses.

Listing example (setting values as listed after the “#” character)
192.168.100.2,1,1 #IP=192.168.100.2, shortcut=1, Group=1

For detailed usage instructions, refer to “Network Configuration File User's Manual.”

How to pair

To ensure better security, pairing between the camera and computer is recommended before use. Pairing is only required on the first connection.

  1. : Double-click the device indicated as “Not yet.”

    The screen below will be displayed.

  2. : On the camera, select MENU → (Network) → [PC Remote Function] → [Pairing](When using the ILCE-9M2) to display the pairing standby screen.

    When using the ILCE-1 : Select MENU → (Network) → [Transfer/Remote] → [PC Remote Function] → [Pairing]

    When using the ILCE-9 : Select MENU → (Network) → [PC Remote(Wired LAN)] → [Pairing]

  3. : Select [Pairing].
  4. : On the camera’s pairing screen, select [OK].
  5. : Turn the power switch of the camera to OFF.

    Once you have turned the power switch to OFF, the pairing information will be saved on the camera. Wait for 10 seconds or longer before turning the switch to ON.

Displaying camera operation screen

When you double click a camera to operate, the "Camera control window" will appear, enabling you to perform various operations.
Do not operate the buttons or dials on the camera while operating the camera using the Camera control window.

Setup guide

For details on the connection, also refer to the following:

Deleting the pairing information

Pairing information is stored on both the camera and the computer (Remote Camera Tool). Select [Tools] → [Delete All Pairing Informationn] to collectively delete all of the pairing information on Remote Camera Tool.

  • Pairing information cannot be deleted individually.
  • To delete pairing information on the camera, reset the network settings by selecting MENU → (Network) → [Reset Network Set.].

Batch camera clock setting

You can set the clocks of the connected cameras all at once.
This function applies to cameras with the Status shown as “Connected” in the Device Selection Window. It does not affect cameras with the Status shown as “Disconnected” or “Unidentified.”

In the Device Selection Window, select [Tools] → [Set All Connected Camera Clock].
When a confirmation window appears, confirm the content of the message and click [Start].

Was this article helpful?
We are holding a simple survey to further improve our services. If you could answer the survey, it would be much appreciated.
Your responses will be used to further develop and improve our products/services. The survey responses will be processed statistically and will not be disclosed in a manner in which an individual can be distinguished.

Why has this not helped?